willemstuursma
Repos
76
Followers
54
Following
7

Lock library to provide serialized execution of PHP code.

865
88

PHP 7.3+ Library for using the Twinfield API.

30
67

PHP implementation of Fowler's Money pattern.

4082
370

Automatically skip sponsor mentions in Youtube videos playing on your Chromecast

17
1

Events

Increase length of hash prefix we send to Sponsorblock API

Created at 2 days ago

Ensure categories are always sent correctly

Make sure we are able to recover from ProcessTimedOutException when listing Chromecasts

Increase length of hash prefix we send to Sponsorblock API

Created at 2 days ago
Created at 2 days ago
Created at 1 week ago
Created at 1 week ago
Created at 1 week ago
create tag
willemstuursma create tag 1.2.0
Created at 1 week ago

Add PHP8 support

Split to 8.0 and 8.1 versions

Remove support for PHP5.6

Remove support for PHP7.0 and change openssl version

Restore openssl previous version and clean up unsupported PHP versions

Add phpstan, validate everything works with PHP 8

Remove PHP versions that are EOL

Merge pull request #25 from sergeyzinder/master

Add PHP8 support

Created at 1 week ago
pull request closed
Add PHP8 support

Update dependencies and unit tests

Created at 1 week ago
issue comment
Add PHP8 support

Thank you for submitting these changes.

Created at 1 week ago

Remove PHP versions that are EOL

Created at 1 week ago

Remove PHP versions that are EOL

Created at 1 week ago

Add phpstan, validate everything works with PHP 8

Created at 1 week ago
issue comment
PHP 8 support

Good morning @sergeyzinder. Pull requests to add PHP 8 support are welcomed.

Created at 1 week ago

Bump minimist from 1.2.5 to 1.2.6

Bumps minimist from 1.2.5 to 1.2.6.


updated-dependencies:

  • dependency-name: minimist dependency-type: indirect ...

Signed-off-by: dependabot[bot] support@github.com

Merge pull request #34 from mollie/dependabot/npm_and_yarn/minimist-1.2.6

Bump minimist from 1.2.5 to 1.2.6

Created at 2 weeks ago
pull request closed
Bump minimist from 1.2.5 to 1.2.6

Bumps minimist from 1.2.5 to 1.2.6.

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

Created at 2 weeks ago
willemstuursma delete branch dependabot/npm_and_yarn/node-fetch-2.6.7
Created at 2 weeks ago

Bump node-fetch from 2.6.1 to 2.6.7

Bumps node-fetch from 2.6.1 to 2.6.7.


updated-dependencies:

  • dependency-name: node-fetch dependency-type: indirect ...

Signed-off-by: dependabot[bot] support@github.com

Merge pull request #33 from mollie/dependabot/npm_and_yarn/node-fetch-2.6.7

Bump node-fetch from 2.6.1 to 2.6.7

Created at 2 weeks ago
pull request closed
Bump node-fetch from 2.6.1 to 2.6.7

Bumps node-fetch from 2.6.1 to 2.6.7.

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

Created at 2 weeks ago
willemstuursma delete branch dependabot/npm_and_yarn/trim-off-newlines-1.0.3
Created at 2 weeks ago

Bump trim-off-newlines from 1.0.1 to 1.0.3

Bumps trim-off-newlines from 1.0.1 to 1.0.3.


updated-dependencies:

  • dependency-name: trim-off-newlines dependency-type: indirect ...

Signed-off-by: dependabot[bot] support@github.com

Merge pull request #32 from mollie/dependabot/npm_and_yarn/trim-off-newlines-1.0.3

Bump trim-off-newlines from 1.0.1 to 1.0.3

Created at 2 weeks ago
pull request closed
Bump trim-off-newlines from 1.0.1 to 1.0.3

Bumps trim-off-newlines from 1.0.1 to 1.0.3.

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

Created at 2 weeks ago

Bump ansi-regex from 3.0.0 to 3.0.1

Bumps ansi-regex from 3.0.0 to 3.0.1.


updated-dependencies:

  • dependency-name: ansi-regex dependency-type: indirect ...

Signed-off-by: dependabot[bot] support@github.com

Merge pull request #43 from mollie/dependabot/npm_and_yarn/ansi-regex-3.0.1

Bump ansi-regex from 3.0.0 to 3.0.1

Created at 2 weeks ago
pull request closed
Bump ansi-regex from 3.0.0 to 3.0.1

Bumps ansi-regex from 3.0.0 to 3.0.1.

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

Created at 2 weeks ago

Bump terser from 4.8.0 to 4.8.1

Bumps terser from 4.8.0 to 4.8.1.


updated-dependencies:

  • dependency-name: terser dependency-type: indirect ...

Signed-off-by: dependabot[bot] support@github.com

Merge pull request #42 from mollie/dependabot/npm_and_yarn/terser-4.8.1

Bump terser from 4.8.0 to 4.8.1

Created at 2 weeks ago
pull request closed
Bump terser from 4.8.0 to 4.8.1

Bumps terser from 4.8.0 to 4.8.1.

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

Created at 2 weeks ago

Bump semver-regex from 3.1.2 to 3.1.4

Bumps semver-regex from 3.1.2 to 3.1.4.


updated-dependencies:

  • dependency-name: semver-regex dependency-type: indirect ...

Signed-off-by: dependabot[bot] support@github.com

Merge pull request #41 from mollie/dependabot/npm_and_yarn/semver-regex-3.1.4

Bump semver-regex from 3.1.2 to 3.1.4

Created at 2 weeks ago
pull request closed
Bump semver-regex from 3.1.2 to 3.1.4

Bumps semver-regex from 3.1.2 to 3.1.4.

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

Created at 2 weeks ago