shadowhand
Repos
26
Followers
554
Following
11

A SQL query builder with zero dependencies

611
47

An example of modern MVC with clean separation

20
2

Events

issue comment
update dependencies

Never mind, I see that #41 was also merged. 👍🏼

Created at 1 day ago
issue comment
update dependencies

@neomerx this was merged with the broken version constraint. Users who are otherwise stuck on psr/log 1.x (or 2.x) won't be able to upgrade.

Created at 1 day ago
AsyncAws errors are not caught

We have been getting a fair number of the following errors:

Unhandled AsyncAws\Core\Exception\Http\NetworkException (0) error: Could not contact remote server.

It seems like these NetworkException errors should be caught inside of getRawItem and throw a CacheItemNotFoundException, as in:

try {
    return $item->getItem();
} catch (NetworkException) {
    throw new CacheItemNotFoundException();
}
Created at 3 days ago
issue comment
Auth0 8.3.0 now requires "cookieSecret" configuration

@evansims strategy seems to be the option we needed to set, rather than cookieSecret! Thanks!

Created at 1 week ago
opened issue
Auth0 8.3.0 requires "cookieSecret" configuration

SDK Version

Other (specify in 'additional context')

PHP Version

PHP 8.1

What happened?

Upon upgrading from 8.2.1 to 8.3.0, the following error appears without any other changes:

Auth0\SDK\Exception\ConfigurationException: `cookieSecret` must be configured

I have no problem making this change, but the README says that cookieSecret is string|null, which implies that it is an optional parameter.

How can we reproduce this issue?

$config = new SdkConfiguration(
    domain: getenv('AUTH0_DOMAIN'),
    clientId: getenv('AUTH0_CLIENT_ID'),
    clientSecret: getenv('AUTH0_CLIENT_SECRET'),
);

Additional context

No response

Created at 1 week ago

Bump commonmarker from 0.23.5 to 0.23.6

Bumps commonmarker from 0.23.5 to 0.23.6.


updated-dependencies:

  • dependency-name: commonmarker dependency-type: indirect ...

Signed-off-by: dependabot[bot] support@github.com

Merge pull request #37 from shadowhand/dependabot/bundler/commonmarker-0.23.6

Bump commonmarker from 0.23.5 to 0.23.6

Created at 1 week ago
pull request closed
Bump commonmarker from 0.23.5 to 0.23.6

Bumps commonmarker from 0.23.5 to 0.23.6.

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself) You can disable automated security fix PRs for this repo from the Security Alerts page.
Created at 1 week ago

Bump commonmarker from 0.23.5 to 0.23.6

Bumps commonmarker from 0.23.5 to 0.23.6.


updated-dependencies:

  • dependency-name: commonmarker dependency-type: indirect ...

Signed-off-by: dependabot[bot] support@github.com

Merge pull request #36 from shadowhand/dependabot/bundler/commonmarker-0.23.6

Bump commonmarker from 0.23.5 to 0.23.6

Created at 1 week ago
pull request closed
Bump commonmarker from 0.23.5 to 0.23.6

Bumps commonmarker from 0.23.5 to 0.23.6.

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself) You can disable automated security fix PRs for this repo from the Security Alerts page.
Created at 1 week ago

Bump commonmarker from 0.23.5 to 0.23.6 in /docs

Bumps commonmarker from 0.23.5 to 0.23.6.


updated-dependencies:

  • dependency-name: commonmarker dependency-type: indirect ...

Signed-off-by: dependabot[bot] support@github.com

Merge pull request #143 from shadowhand/dependabot/bundler/docs/commonmarker-0.23.6

Bump commonmarker from 0.23.5 to 0.23.6 in /docs

Created at 1 week ago
pull request closed
Bump commonmarker from 0.23.5 to 0.23.6 in /docs

Bumps commonmarker from 0.23.5 to 0.23.6.

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself) You can disable automated security fix PRs for this repo from the Security Alerts page.
Created at 1 week ago
Class 'League\OAuth2\Client\Provider\Google' not found
require '../autoload.php';

This has to be the first thing in the file. You're attempting to use the class before it can be discovered. Make sure the path is correct.

Created at 1 week ago
Class 'League\OAuth2\Client\Provider\Google' not found

I did the step by step, has anyone encountered this error?

Fatal error: Uncaught Error: Class 'League\OAuth2\Client\Provider\Google' not found in /www/wwwroot/iqfacil/PHPMailer/get_oauth_token.php:116 Stack trace: #0 {main} thrown in /www/wwwroot/iqfacil/PHPMailer/get_oauth_token.php on line 116

Created at 1 week ago
Class 'League\OAuth2\Client\Provider\Google' not found

Seems like you might not be requiring the composer autoload.php file.

Created at 1 week ago
issue comment
Allow expanded configuration

Thank you!

Created at 2 weeks ago
delete branch
shadowhand delete branch fix/expanded-http-routing
Created at 2 weeks ago
closed issue
Compile on ARM64 as well as AMD64

Our company is switching over to Apple M1 laptops within the next couple of months and I noticed that the Bref Docker images are only available as amd64 images.

Could we please get arm64 in addition to amd64 images? 🥺

Created at 2 weeks ago
closed issue
Compile on ARM64 as well as AMD64

Our company is switching over to Apple M1 laptops within the next couple of months and I noticed that the Bref Docker images are only available as amd64 images.

Could we please get arm64 in addition to amd64 images? 🥺

Created at 2 weeks ago