sevagh
Repos
53
Followers
125
Following
12

Events

Created at 3 days ago
sevagh create branch feat/cuml-cugraph-private-clone-support
Created at 1 week ago

Add branch-22.12 of cudf

Created at 1 week ago
pull request closed
[skip gpuci] Feat/cibuildwheel

Build pip wheels from GitHub Actions.

Created at 1 week ago
issue comment
[skip gpuci] Feat/cibuildwheel

Superseded by #901

Created at 1 week ago

Use rmm branch-22.12 for pip wheels

Created at 1 week ago

Define test-cu11 dependencies on rmm-cu11 and ucx-py-cu11

Created at 1 week ago
delete branch
sevagh delete branch feat/cibuildwheel
Created at 1 week ago
pull request closed
[skip gpuci] Create pure-wheel workflow for dask-cuda

Create a workflow to upload dask-cuda==22.10.0 to our internal pypi index and unblock CI.

Created at 1 week ago
issue comment
[skip gpuci] Create pure-wheel workflow for dask-cuda

Superseded by #1049

Created at 1 week ago
pull request opened
[skip gpuci] Build dask-cuda internally to use for RAPIDS CI

During the pip wheel CI for RAPIDS projects (e.g. cudf/cugraph/cuml), we need to be able to install dask-cuda.

Dask-cuda is released to PyPI.org on a specific release schedule.

This PR allows dask-cuda wheels to get built using the RAPIDS pip wheel workflows, published to the RAPIDS nightly index. That way, RAPIDS CI can have access to an installable dask-cuda pip wheel before the PyPI release.

This shouldn't affect external users, since our internal nightly index is not accessible to the public (yet).

Created at 1 week ago
create branch
sevagh create branch feat/cibuildwheel-2
Created at 1 week ago

Align version with wheel version (#1161)

  • Align version with wheel version

  • Adjust setup.py to pass flake8 + black

  • Only override the version once

  • Complain if RAPIDS_PY_WHEEL_VERSIONEER_OVERRIDE is set but empty

Created at 1 week ago
pull request closed
Align __version__ with wheel version

In the pip wheels, the versioneer version is overwritten with an env var, RAPIDS_PY_WHEEL_VERSIONEER_OVERRIDE in the setup.py version.

However, the __version__ metadata of the package doesn't match this override. This fix propagates the override to __version__ also.

Created at 1 week ago
push

Remove pull-request push trigger

Created at 1 week ago
issue comment
Align __version__ with wheel version

I also incorporated more suggestions from Lawrence in: https://github.com/rapidsai/ptxcompiler/pull/31

Created at 1 week ago
push

Complain if RAPIDS_PY_WHEEL_VERSIONEER_OVERRIDE is set but empty

Created at 1 week ago
push

Complain if RAPIDS_PY_WHEEL_VERSIONEER_OVERRIDE is set but empty

Created at 1 week ago

Complain if RAPIDS_PY_WHEEL_VERSIONEER_OVERRIDE is set but empty

Created at 1 week ago