pr7prashant
Repos
9
Followers
2
Following
3

Concise, consistent, and legible badges in SVG and raster format

18996
5145

Collection of LeetCode questions.

0
0

Javascript client

1588
394

Build Better Websites. Create modern, resilient user experiences with web fundamentals.

22006
1715

Events

migrate danger CI job to GHA (#8477)

  • migrate danger CI job to GHA

  • constrain triggers

  • prettier

Add docstrings for pipenv helpers (#8787)

  • add docstrings for pipenv helpers

  • update param description

Co-authored-by: chris48s chris48s@users.noreply.github.com

Created at 3 weeks ago
delete branch
pr7prashant delete branch docstrings-pipenv
Created at 3 weeks ago

update param description

Created at 3 weeks ago

Time: 6 ms (20.93%), Space: 8.5 MB (44.83%) - LeetHub

Created at 3 weeks ago

Create README - LeetHub

Created at 3 weeks ago

Attach NOTES - LeetHub

Created at 3 weeks ago
pull request opened
Add docstrings for pipenv helpers
  • Added docstrings for pipenv-helpers service
Created at 3 weeks ago
create branch
pr7prashant create branch docstrings-pipenv
Created at 3 weeks ago

Docstrings for php-version service (#8766)

  • add docstrings for php-version service

  • update docstring for resource-cache service

  • update docstring param type

chore(deps-dev): bump eslint-config-prettier from 8.5.0 to 8.6.0 (#8774)

Bumps eslint-config-prettier from 8.5.0 to 8.6.0.


updated-dependencies:

  • dependency-name: eslint-config-prettier dependency-type: direct:development update-type: version-update:semver-minor ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps): bump prom-client from 14.1.0 to 14.1.1 (#8777)

Bumps prom-client from 14.1.0 to 14.1.1.


updated-dependencies:

  • dependency-name: prom-client dependency-type: direct:production update-type: version-update:semver-patch ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps-dev): bump danger from 11.2.0 to 11.2.1 (#8775)

Bumps danger from 11.2.0 to 11.2.1.


updated-dependencies:

  • dependency-name: danger dependency-type: direct:development update-type: version-update:semver-patch ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps): bump @sentry/node from 7.28.1 to 7.29.0 (#8780)

Bumps @sentry/node from 7.28.1 to 7.29.0.


updated-dependencies:

  • dependency-name: "@sentry/node" dependency-type: direct:production update-type: version-update:semver-minor ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps-dev): bump @typescript-eslint/eslint-plugin (#8781)

Bumps @typescript-eslint/eslint-plugin from 5.47.1 to 5.48.0.


updated-dependencies:

  • dependency-name: "@typescript-eslint/eslint-plugin" dependency-type: direct:development update-type: version-update:semver-minor ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps-dev): bump cypress from 12.2.0 to 12.3.0 (#8778)

Bumps cypress from 12.2.0 to 12.3.0.


updated-dependencies:

  • dependency-name: cypress dependency-type: direct:development update-type: version-update:semver-minor ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps-dev): bump @babel/core from 7.20.7 to 7.20.12 (#8779)

Bumps @babel/core from 7.20.7 to 7.20.12.


updated-dependencies:

  • dependency-name: "@babel/core" dependency-type: direct:development update-type: version-update:semver-patch ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>

chore(deps): bump json5 from v2.2.1 to v2.2.3 (#8785)

Bumps json5


updated-dependencies:

  • dependency-name: json5 dependency-type: indirect ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>

deprecate [apm] service (#8773)

Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

Created at 3 weeks ago
delete branch
pr7prashant delete branch docstrings-php-version
Created at 3 weeks ago

Changelog for Release server-2023-01-01 (#8765)

  • Update Changelog

  • Update CHANGELOG.md

Co-authored-by: release[bot] actions@users.noreply.github.com Co-authored-by: chris48s chris48s@users.noreply.github.com

deprecate lgtm; lgtm service tests should be passing (#8771)

Created at 4 weeks ago

deprecate lgtm; lgtm service tests should be passing (#8771)

Merge branch 'master' into docstrings-php-version

Created at 4 weeks ago

update docstring param type

Created at 4 weeks ago

Time: 131 ms (31.26%), Space: 12.2 MB (30.23%) - LeetHub

Created at 1 month ago

Attach NOTES - LeetHub

Created at 1 month ago

Create README - LeetHub

Created at 1 month ago

add clangd lsp in mason config

Created at 1 month ago

Attach NOTES - LeetHub

Created at 1 month ago

Create README - LeetHub

Created at 1 month ago

Changelog for Release server-2023-01-01 (#8765)

  • Update Changelog

  • Update CHANGELOG.md

Co-authored-by: release[bot] actions@users.noreply.github.com Co-authored-by: chris48s chris48s@users.noreply.github.com

Merge branch 'master' into docstrings-php-version

Created at 1 month ago

chore(deps-dev): bump @typescript-eslint/eslint-plugin (#8614)

Bumps @typescript-eslint/eslint-plugin from 5.42.0 to 5.42.1.


updated-dependencies:

  • dependency-name: "@typescript-eslint/eslint-plugin" dependency-type: direct:development update-type: version-update:semver-patch ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>

chore(deps): bump simple-icons from 7.18.0 to 7.19.0 (#8609)

Bumps simple-icons from 7.18.0 to 7.19.0.


updated-dependencies:

  • dependency-name: simple-icons dependency-type: direct:production update-type: version-update:semver-minor ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps-dev): bump @babel/core from 7.19.6 to 7.20.2 (#8611)

Bumps @babel/core from 7.19.6 to 7.20.2.


updated-dependencies:

  • dependency-name: "@babel/core" dependency-type: direct:development update-type: version-update:semver-minor ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps): bump socket.io-parser from 3.3.2 to 3.3.3 (#8607)

Bumps socket.io-parser from 3.3.2 to 3.3.3.


updated-dependencies:

  • dependency-name: socket.io-parser dependency-type: indirect ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps): bump @sentry/node from 7.17.4 to 7.19.0 (#8616)

Bumps @sentry/node from 7.17.4 to 7.19.0.


updated-dependencies:

  • dependency-name: "@sentry/node" dependency-type: direct:production update-type: version-update:semver-minor ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps-dev): bump cypress from 10.11.0 to 11.0.1 (#8615)

Bumps cypress from 10.11.0 to 11.0.1.


updated-dependencies:

  • dependency-name: cypress dependency-type: direct:development update-type: version-update:semver-major ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps-dev): bump chai and @types/chai (#8612)

Bumps chai and @types/chai. These dependencies needed to be updated together.

Updates chai from 4.3.6 to 4.3.7

Updates @types/chai from 4.3.3 to 4.3.4


updated-dependencies:

  • dependency-name: chai dependency-type: direct:development update-type: version-update:semver-patch
  • dependency-name: "@types/chai" dependency-type: direct:development update-type: version-update:semver-patch ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps-dev): bump sinon from 14.0.1 to 14.0.2 (#8613)

Bumps sinon from 14.0.1 to 14.0.2.


updated-dependencies:

  • dependency-name: sinon dependency-type: direct:development update-type: version-update:semver-patch ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps): bump @renovatebot/ruby-semver from 1.1.6 to 1.1.7 (#8619)

Bumps @renovatebot/ruby-semver from 1.1.6 to 1.1.7.


updated-dependencies:

  • dependency-name: "@renovatebot/ruby-semver" dependency-type: direct:production update-type: version-update:semver-patch ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>

[Coveralls] for GitLab (#8584)

  • Added GitLab to Coveralls badge + added redirect

  • why does the old redirect accept slash in the user param

  • rename test

  • modify the old redirector test - but it still doesnt work

  • tests are passing

  • add missing redirector tests

Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

[factorio-mod-portal] services (#8625)

  • add latest version service

  • add game version service

  • update game version service, includes version range

  • add game version and latest version service tests

  • add last updated service & tests

  • add downloads service

  • url changes

  • add 'range' query to factorio versions

  • renamed function to transform

  • validate downloads via nonNegativeInteger

https://github.com/badges/shields/pull/8625#discussion_r1021557183

  • change version route to /v

https://github.com/badges/shields/pull/8625#discussion_r1021558937

  • factorio-version category to platform-support

https://github.com/badges/shields/pull/8625#discussion_r1021557896

  • change downloads route to /dt

https://github.com/badges/shields/pull/8625#discussion_r1021559841

  • version validator to isVPlusDottedVersionNClauses

https://github.com/badges/shields/pull/8625#discussion_r1021563736

  • removed range query param from factorio-version

https://github.com/badges/shields/pull/8625#discussion_r1021568758

Add [modrinth] version (#8604)

  • Add a Modrinth version badge

  • Use a more lenient pattern when testing version

  • Update version schema

Co-authored-by: chris48s chris48s@users.noreply.github.com

  • Update route base

Co-authored-by: chris48s chris48s@users.noreply.github.com

chore(deps-dev): bump cypress from 11.0.1 to 11.1.0 (#8633)

Bumps cypress from 11.0.1 to 11.1.0.


updated-dependencies:

  • dependency-name: cypress dependency-type: direct:development update-type: version-update:semver-minor ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps): bump got from 12.5.2 to 12.5.3 (#8636)

Bumps got from 12.5.2 to 12.5.3.


updated-dependencies:

  • dependency-name: got dependency-type: direct:production update-type: version-update:semver-patch ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps): bump @sentry/node from 7.19.0 to 7.20.0 (#8640)

Bumps @sentry/node from 7.19.0 to 7.20.0.


updated-dependencies:

  • dependency-name: "@sentry/node" dependency-type: direct:production update-type: version-update:semver-minor ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps): bump actions/dependency-review-action from 2 to 3 (#8628)

Bumps actions/dependency-review-action from 2 to 3.


updated-dependencies:

  • dependency-name: actions/dependency-review-action dependency-type: direct:production update-type: version-update:semver-major ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com> Co-authored-by: chris48s chris48s@users.noreply.github.com

chore(deps-dev): bump mocha-junit-reporter from 2.1.1 to 2.2.0 (#8638)

Bumps mocha-junit-reporter from 2.1.1 to 2.2.0.


updated-dependencies:

  • dependency-name: mocha-junit-reporter dependency-type: direct:development update-type: version-update:semver-minor ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps): bump loader-utils from 1.4.1 to 1.4.2 (#8630)

Bumps loader-utils from 1.4.1 to 1.4.2.


updated-dependencies:

  • dependency-name: loader-utils dependency-type: indirect ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps-dev): bump typescript from 4.8.4 to 4.9.3 (#8637)

Bumps typescript from 4.8.4 to 4.9.3.


updated-dependencies:

  • dependency-name: typescript dependency-type: direct:development update-type: version-update:semver-minor ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps-dev): bump danger from 11.1.4 to 11.2.0 (#8634)

Bumps danger from 11.1.4 to 11.2.0.


updated-dependencies:

  • dependency-name: danger dependency-type: direct:development update-type: version-update:semver-minor ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

Created at 1 month ago
pull request opened
Docstrings for php-version service
  • Added docstrings for php-version service
  • Updated docstring for resource-cache service
Created at 1 month ago
create branch
pr7prashant create branch docstrings-php-version
Created at 1 month ago

chore(deps-dev): bump @typescript-eslint/eslint-plugin (#8614)

Bumps @typescript-eslint/eslint-plugin from 5.42.0 to 5.42.1.


updated-dependencies:

  • dependency-name: "@typescript-eslint/eslint-plugin" dependency-type: direct:development update-type: version-update:semver-patch ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>

chore(deps): bump simple-icons from 7.18.0 to 7.19.0 (#8609)

Bumps simple-icons from 7.18.0 to 7.19.0.


updated-dependencies:

  • dependency-name: simple-icons dependency-type: direct:production update-type: version-update:semver-minor ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps-dev): bump @babel/core from 7.19.6 to 7.20.2 (#8611)

Bumps @babel/core from 7.19.6 to 7.20.2.


updated-dependencies:

  • dependency-name: "@babel/core" dependency-type: direct:development update-type: version-update:semver-minor ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps): bump socket.io-parser from 3.3.2 to 3.3.3 (#8607)

Bumps socket.io-parser from 3.3.2 to 3.3.3.


updated-dependencies:

  • dependency-name: socket.io-parser dependency-type: indirect ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps): bump @sentry/node from 7.17.4 to 7.19.0 (#8616)

Bumps @sentry/node from 7.17.4 to 7.19.0.


updated-dependencies:

  • dependency-name: "@sentry/node" dependency-type: direct:production update-type: version-update:semver-minor ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps-dev): bump cypress from 10.11.0 to 11.0.1 (#8615)

Bumps cypress from 10.11.0 to 11.0.1.


updated-dependencies:

  • dependency-name: cypress dependency-type: direct:development update-type: version-update:semver-major ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps-dev): bump chai and @types/chai (#8612)

Bumps chai and @types/chai. These dependencies needed to be updated together.

Updates chai from 4.3.6 to 4.3.7

Updates @types/chai from 4.3.3 to 4.3.4


updated-dependencies:

  • dependency-name: chai dependency-type: direct:development update-type: version-update:semver-patch
  • dependency-name: "@types/chai" dependency-type: direct:development update-type: version-update:semver-patch ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps-dev): bump sinon from 14.0.1 to 14.0.2 (#8613)

Bumps sinon from 14.0.1 to 14.0.2.


updated-dependencies:

  • dependency-name: sinon dependency-type: direct:development update-type: version-update:semver-patch ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps): bump @renovatebot/ruby-semver from 1.1.6 to 1.1.7 (#8619)

Bumps @renovatebot/ruby-semver from 1.1.6 to 1.1.7.


updated-dependencies:

  • dependency-name: "@renovatebot/ruby-semver" dependency-type: direct:production update-type: version-update:semver-patch ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com>

[Coveralls] for GitLab (#8584)

  • Added GitLab to Coveralls badge + added redirect

  • why does the old redirect accept slash in the user param

  • rename test

  • modify the old redirector test - but it still doesnt work

  • tests are passing

  • add missing redirector tests

Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

[factorio-mod-portal] services (#8625)

  • add latest version service

  • add game version service

  • update game version service, includes version range

  • add game version and latest version service tests

  • add last updated service & tests

  • add downloads service

  • url changes

  • add 'range' query to factorio versions

  • renamed function to transform

  • validate downloads via nonNegativeInteger

https://github.com/badges/shields/pull/8625#discussion_r1021557183

  • change version route to /v

https://github.com/badges/shields/pull/8625#discussion_r1021558937

  • factorio-version category to platform-support

https://github.com/badges/shields/pull/8625#discussion_r1021557896

  • change downloads route to /dt

https://github.com/badges/shields/pull/8625#discussion_r1021559841

  • version validator to isVPlusDottedVersionNClauses

https://github.com/badges/shields/pull/8625#discussion_r1021563736

  • removed range query param from factorio-version

https://github.com/badges/shields/pull/8625#discussion_r1021568758

Add [modrinth] version (#8604)

  • Add a Modrinth version badge

  • Use a more lenient pattern when testing version

  • Update version schema

Co-authored-by: chris48s chris48s@users.noreply.github.com

  • Update route base

Co-authored-by: chris48s chris48s@users.noreply.github.com

chore(deps-dev): bump cypress from 11.0.1 to 11.1.0 (#8633)

Bumps cypress from 11.0.1 to 11.1.0.


updated-dependencies:

  • dependency-name: cypress dependency-type: direct:development update-type: version-update:semver-minor ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps): bump got from 12.5.2 to 12.5.3 (#8636)

Bumps got from 12.5.2 to 12.5.3.


updated-dependencies:

  • dependency-name: got dependency-type: direct:production update-type: version-update:semver-patch ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps): bump @sentry/node from 7.19.0 to 7.20.0 (#8640)

Bumps @sentry/node from 7.19.0 to 7.20.0.


updated-dependencies:

  • dependency-name: "@sentry/node" dependency-type: direct:production update-type: version-update:semver-minor ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps): bump actions/dependency-review-action from 2 to 3 (#8628)

Bumps actions/dependency-review-action from 2 to 3.


updated-dependencies:

  • dependency-name: actions/dependency-review-action dependency-type: direct:production update-type: version-update:semver-major ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com> Co-authored-by: chris48s chris48s@users.noreply.github.com

chore(deps-dev): bump mocha-junit-reporter from 2.1.1 to 2.2.0 (#8638)

Bumps mocha-junit-reporter from 2.1.1 to 2.2.0.


updated-dependencies:

  • dependency-name: mocha-junit-reporter dependency-type: direct:development update-type: version-update:semver-minor ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps): bump loader-utils from 1.4.1 to 1.4.2 (#8630)

Bumps loader-utils from 1.4.1 to 1.4.2.


updated-dependencies:

  • dependency-name: loader-utils dependency-type: indirect ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps-dev): bump typescript from 4.8.4 to 4.9.3 (#8637)

Bumps typescript from 4.8.4 to 4.9.3.


updated-dependencies:

  • dependency-name: typescript dependency-type: direct:development update-type: version-update:semver-minor ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

chore(deps-dev): bump danger from 11.1.4 to 11.2.0 (#8634)

Bumps danger from 11.1.4 to 11.2.0.


updated-dependencies:

  • dependency-name: danger dependency-type: direct:development update-type: version-update:semver-minor ...

Signed-off-by: dependabot[bot] support@github.com

Signed-off-by: dependabot[bot] support@github.com Co-authored-by: dependabot[bot] <49699333+dependabot[bot]@users.noreply.github.com> Co-authored-by: repo-ranger[bot] <39074581+repo-ranger[bot]@users.noreply.github.com>

Created at 1 month ago

Time: 0 ms (100.00%), Space: 6.4 MB (82.12%) - LeetHub

Created at 1 month ago

Create README - LeetHub

Created at 1 month ago