mike-works
Repos
21

Mike North's Web Security Course

240
110

👨‍🏫 Mike's Sass Fundamentals Course

139
203

Mike North's 2018 TypeScript Fundamentals Course

863
726

👨‍🏫 Mike's Elixir Fundamentals Course

21
7

👨‍🏫 Mike's Ember Pro Course

10
6

👨‍🏫 Mike & Steve's Progressive Web Fundamentals Course

267
128

Events

dependabot[bot] delete branch dependabot/npm_and_yarn/ua-parser-js-0.7.31
Created at 6 days ago
pull request closed
chore(deps): bump ua-parser-js from 0.7.18 to 0.7.31

Bumps ua-parser-js from 0.7.18 to 0.7.31.

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

Created at 6 days ago
chore(deps): bump ua-parser-js from 0.7.18 to 0.7.31

Superseded by #1018.

Created at 6 days ago
dependabot[bot] create branch dependabot/npm_and_yarn/ua-parser-js-0.7.33
Created at 6 days ago
pull request opened
chore(deps): bump ua-parser-js from 0.7.18 to 0.7.33

Bumps ua-parser-js from 0.7.18 to 0.7.33.

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

Created at 6 days ago
fix(deps): update dependency commander to v10

Mend Renovate

This PR contains the following updates:

| Package | Change | Age | Adoption | Passing | Confidence | |---|---|---|---|---|---| | commander | 2.20.3 -> 10.0.0 | age | adoption | passing | confidence |


Release Notes

v10.0.0

Compare Source

Added
Changed
  • Breaking: Commander 10 requires Node.js v14 or higher

v9.5.0

Compare Source

Added
  • .getOptionValueSourceWithGlobals() ([#​1832])
  • showGlobalOptions for .configureHelp{} and Help ([#​1828])

v9.4.1

Compare Source

Fixed
  • .setOptionValue() now also clears option source ([#​1795])
  • TypeScript: add implied to OptionValueSource for option values set by using .implies() ([#​1794])
  • TypeScript : add undefined to return type of .getOptionValueSource() ([#​1794])
Changed
  • additions to README

v9.4.0

Compare Source

Added
  • preSubcommand hook called before direct subcommands ([#​1763])
Fixed
  • export InvalidOptionArgumentError in esm ([#​1756])
Changed

v9.3.0

Compare Source

Added
  • .summary() for a short summary to use instead of description when listing subcommands in help ([#​1726])
  • Option.implies() to set other option values when the option is specified ([#​1724])
  • updated Chinese README with 9.x changes ([#​1727])
Fixed
  • TypeScript: add string[] to .options() default value parameter type for use with variadic options ([#​1721])
Deprecated
  • multi-character short option flag (e.g. -ws) ([#​1718])

v9.2.0

Compare Source

Added
  • conditional export of 'types' for upcoming TypeScript module resolution ([#​1703])
  • example file showing two ways to add global options to subcommands ([#​1708])
Fixed
  • detect option conflicts in parent commands of called subcommand ([#​1710])
Changed
  • replace deprecated String.prototype.substr ([#​1706])

v9.1.0

Compare Source

Added
  • Option .conflicts() to set conflicting options which can not be specified together ([#​1678])
  • (developer) CodeQL configuration for GitHub Actions ([#​1698])

v9.0.0

Compare Source

Added
  • simpler ECMAScript import ([#​1589])
  • Option.preset() allows specifying value/arg for option when used without option-argument (especially optional, but also boolean option) ([#​1652])
  • .executableDir() for custom search for subcommands ([#​1571])
  • throw with helpful message if pass Option to .option() or .requiredOption() ([#​1655])
  • .error() for generating errors from client code just like Commander generated errors, with support for .configureOutput(), .exitOverride(), and .showHelpAfterError() ([#​1675])
  • .optsWithGlobals() to return merged local and global options ([#​1671])
Changed
  • Breaking: Commander 9 requires Node.js v12.20.0 or higher
  • update package-lock.json to lockfile@2 format ([#​1659])
  • showSuggestionAfterError is now on by default ([#​1657])
  • Breaking: default value specified for boolean option now always used as default value (see .preset() to match some previous behaviours) ([#​1652])
  • default value for boolean option only shown in help if true/false ([#​1652])
  • use command name as prefix for subcommand stand-alone executable name (with fallback to script name for backwards compatibility) ([#​1571])
  • allow absolute path with executableFile ([#​1571])
  • removed restriction that nested subcommands must specify executableFile ([#​1571])
  • TypeScript: allow passing readonly string array to .choices() [(#​1667)]
  • TypeScript: allow passing readonly string array to .parse(), .parseAsync(), .aliases() [(#​1669)]
Fixed
  • option with optional argument not supplied on command line now works when option already has a value, whether from default value or from previous arguments ([#​1652])
Removed
  • Breaking: removed internal fallback to require.main.filename when script not known from arguments passed to .parse() (can supply details using .name(), and .executableDir() or executableFile) ([#​1571])

v8.3.0

Compare Source

Added
  • .getOptionValueSource() and .setOptionValueWithSource(), where expected values for source are one of 'default', 'env', 'config', 'cli' ([#​1613])
Deprecated
  • .command('*'), use default command instead ([#​1612])
  • on('command:*'), use .showSuggestionAfterError() instead ([#​1612])

v8.2.0

Compare Source

Added
  • .showSuggestionAfterError() to show suggestions after unknown command or unknown option ([#​1590])
  • add Option support for values from environment variables using .env() ([#​1587])
Changed
  • show error for unknown global option before subcommand (rather than just help) ([#​1590])
Removed
  • TypeScript declaration of unimplemented Option method argumentRejected

v8.1.0

Compare Source

Added
  • .copyInheritedSettings() ([#​1557])
  • update Chinese translations of documentation for Commander v8 ([#​1570])
  • Argument methods for .argRequired() and .argOptional() ([#​1567])

v8.0.0

Compare Source

Added
  • .argument(name, description) for adding command-arguments ([#​1490])
    • supports default value for optional command-arguments ([#​1508])
    • supports custom processing function ([#​1508])
  • .createArgument() factory method ([#​1497])
  • .addArgument() ([#​1490])
  • Argument supports .choices() ([#​1525])
  • .showHelpAfterError() to display full help or a custom message after an error ([#​1534])
  • .hook() with support for 'preAction' and 'postAction' callbacks ([#​1514])
  • client typing of .opts() return type using TypeScript generics ([#​1539])
  • the number of command-arguments is checked for programs without an action handler ([#​1502])
  • .getOptionValue() and .setOptionValue() ([#​1521])
Changed
  • refactor and simplify TypeScript declarations (with no default export) ([#​1520])
  • .parseAsync() is now declared as async ([#​1513])
  • Breaking: Help method .visibleArguments() returns array of Argument ([#​1490])
  • Breaking: Commander 8 requires Node.js 12 or higher ([#​1500])
  • Breaking: CommanderError code commander.invalidOptionArgument renamed commander.invalidArgument ([#​1508])
  • Breaking: TypeScript declaration for .addTextHelp() callback no longer allows result of undefined, now just string ([#​1516])
  • refactor index.tab into a file per class ([#​1522])
  • remove help suggestion from "unknown command" error message (see .showHelpAfteError()) ([#​1534])
  • Command property .arg initialised to empty array (was previously undefined) ([#​1529])
  • update dependencies
Deprecated
  • second parameter of cmd.description(desc, argDescriptions) for adding argument descriptions ([#​1490])
    • (use new .argument(name, description) instead)
  • InvalidOptionArgumentError (replaced by InvalidArgumentError) ([#​1508])
Removed
  • Breaking: TypeScript declaration for default export of global Command object ([#​1520])
    • (still available as named program export)
Migration Tips

If you have a simple program without an action handler, you will now get an error if there are missing command-arguments.

program
  .option('-d, --debug')
  .arguments('<file>');
program.parse();
$ node trivial.js 
error: missing required argument 'file'

If you want to show the help in this situation, you could check the arguments before parsing:

if (process.argv.length === 2)
  program.help();
program.parse();

Or, you might choose to show the help after any user error:

program.showHelpAfterError();

v7.2.0

Compare Source

Added
  • TypeScript typing for parent property on Command ([#​1475])
  • TypeScript typing for .attributeName() on Option ([#​1483])
  • support information in package ([#​1477])
Changed
  • improvements to error messages, README, and tests
  • update dependencies

v7.1.0

Compare Source

Added
  • support for named imports from ECMAScript modules ([#​1440])
  • add .cjs to list of expected script file extensions ([#​1449])
  • allow using option choices and variadic together ([#​1454])
Fixed
  • replace use of deprecated process.mainModule ([#​1448])
  • regression for legacy command('*') and call when command line includes options ([#​1464])
  • regression for on('command:*', ...) and call when command line includes unknown options ([#​1464])
  • display best error for combination of unknown command and unknown option (i.e. unknown command) ([#​1464])
Changed
  • make TypeScript typings tests stricter ([#​1453])
  • improvements to README and tests

v7.0.0

Compare Source

Added
  • .enablePositionalOptions() to let program and subcommand reuse same option ([#​1427])
  • .passThroughOptions() to pass options through to other programs without needing -- ([#​1427])
  • .allowExcessArguments(false) to show an error message if there are too many command-arguments on command line for the action handler ([#​1409])
  • .configureOutput() to modify use of stdout and stderr or customise display of errors ([#​1387])
  • use .addHelpText() to add text before or after the built-in help, for just current command or also for all subcommands ([#​1296])
  • enhance Option class ([#​1331])
    • allow hiding options from help
    • allow restricting option arguments to a list of choices
    • allow setting how default value is shown in help
  • .createOption() to support subclassing of automatically created options (like .createCommand()) ([#​1380])
  • refactor the code generating the help into a separate public Help class ([#​1365])
    • support sorting subcommands and options in help
    • support specifying wrap width (columns)
    • allow subclassing Help class
    • allow configuring Help class without subclassing
Changed
  • Breaking: options are stored safely by default, not as properties on the command ([#​1409])
    • this especially affects accessing options on program, use program.opts()
    • revert behaviour with .storeOptionsAsProperties()
  • Breaking: action handlers are passed options and command separately ([#​1409])
  • deprecated callback parameter to .help() and .outputHelp() (removed from README) ([#​1296])
  • Breaking: errors now displayed using process.stderr.write() instead of console.error()
  • deprecate .on('--help') (removed from README) ([#​1296])
  • initialise the command description to empty string (previously undefined) ([#​1365])
  • document and annotate deprecated routines ([#​1349])
Fixed
  • wrapping bugs in help ([#​1365])
    • first line of command description was wrapping two characters early
    • pad width calculation was not including help option and help command
    • pad width calculation was including hidden options and commands
  • improve backwards compatibility for custom command event listeners ([#​1403])
Deleted
  • Breaking: .passCommandToAction() ([#​1409])
    • no longer needed as action handler is passed options and command
  • Breaking: "extra arguments" parameter to action handler ([#​1409])
    • if being used to detect excess arguments, there is now an error available by setting .allowExcessArguments(false)
Migration Tips

The biggest change is the parsed option values. Previously the options were stored by default as properties on the command object, and now the options are stored separately.

If you wish to restore the old behaviour and get running quickly you can call .storeOptionsAsProperties(). To allow you to move to the new code patterns incrementally, the action handler will be passed the command twice, to match the new "options" and "command" parameters (see below).

program options

Use the .opts() method to access the options. This is available on any command but is used most with the program.

program.option('-d, --debug');
program.parse();
// Old code before Commander 7
if (program.debug) console.log(`Program name is ${program.name()}`);
// New code
const options = program.opts();
if (options.debug) console.log(`Program name is ${program.name()}`);

action handler

The action handler gets passed a parameter for each command-argument you declared. Previously by default the next parameter was the command object with the options as properties. Now the next two parameters are instead the options and the command. If you only accessed the options there may be no code changes required.

program
  .command('compress <filename>')
  .option('-t, --trace')
  // Old code before Commander 7
  .action((filename, cmd) => {
    if (cmd.trace) console.log(`Command name is ${cmd.name()}`);
  });
  // New code
  .action((filename, options, command) => {
    if (options.trace) console.log(`Command name is ${command.name()}`);
  });

If you already set .storeOptionsAsProperties(false) you may still need to adjust your code.

program
  .command('compress <filename>')
  .storeOptionsAsProperties(false)
  .option('-t, --trace')
  // Old code before Commander 7
  .action((filename, command) => {
    if (command.opts().trace) console.log(`Command name is ${command.name()}`);
  });
   // New code
   .action((filename, options, command) => {
      if (command.opts().trace) console.log(`Command name is ${command.name()}`);
   });

v6.2.1

Compare Source

Fixed
  • some tests failed if directory path included a space ([#​1390])

v6.2.0

Compare Source

Added
  • added 'tsx' file extension for stand-alone executable subcommands ([#​1368])
  • documented second parameter to .description() to describe command arguments ([#​1353])
  • documentation of special cases with options taking varying numbers of option-arguments ([#​1332])
  • documentation for terminology ([#​1361])
Fixed
  • add missing TypeScript definition for `.addHelpCommand()' ([#​1375])
  • removed blank line after "Arguments:" in help, to match "Options:" and "Commands:" ([#​1360])
Changed
  • update dependencies

v6.1.0

Compare Source

Added
  • include URL to relevant section of README for error for potential conflict between Command properties and option values ([#​1306])
  • .combineFlagAndOptionalValue(false) to ease upgrade path from older versions of Commander ([#​1326])
  • allow disabling the built-in help option using .helpOption(false) ([#​1325])
  • allow just some arguments in argumentDescription to .description() ([#​1323])
Changed
  • tidy async test and remove lint override ([#​1312])
Fixed
  • executable subcommand launching when script path not known ([#​1322])

v6.0.0

Compare Source

Added
  • add support for variadic options ([#​1250])
  • allow options to be added with just a short flag ([#​1256])
    • Breaking the option property has same case as flag. e.g. flag -n accessed as opts().n (previously uppercase)
  • Breaking throw an error if there might be a clash between option name and a Command property, with advice on how to resolve ([#​1275])
Fixed
  • Options which contain -no- in the middle of the option flag should not be treated as negatable. ([#​1301])

v5.1.0

Compare Source

Added
  • support for multiple command aliases, the first of which is shown in the auto-generated help ([#​531], [#​1236])
  • configuration support in addCommand() for hidden and isDefault ([#​1232])
Fixed
  • omit masked help flags from the displayed help ([#​645], [#​1247])
  • remove old short help flag when change help flags using helpOption ([#​1248])
Changed
  • remove use of arguments to improve auto-generated help in editors ([#​1235])
  • rename .command() configuration noHelp to hidden (but not remove old support) ([#​1232])
  • improvements to documentation
  • update dependencies
  • update tested versions of node
  • eliminate lint errors in TypeScript ([#​1208])

v5.0.0

Compare Source

Added
  • support for nested commands with action-handlers ([#​1] [#​764] [#​1149])
  • .addCommand() for adding a separately configured command ([#​764] [#​1149])
  • allow a non-executable to be set as the default command ([#​742] [#​1149])
  • implicit help command when there are subcommands (previously only if executables) ([#​1149])
  • customise implicit help command with .addHelpCommand() ([#​1149])
  • display error message for unknown subcommand, by default ([#​432] [#​1088] [#​1149])
  • display help for missing subcommand, by default ([#​1088] [#​1149])
  • combined short options as single argument may include boolean flags and value flag and value (e.g. -a -b -p 80 can be written as -abp80) ([#​1145])
  • .parseOption() includes short flag and long flag expansions ([#​1145])
  • .helpInformation() returns help text as a string, previously a private routine ([#​1169])
  • .parse() implicitly uses process.argv if arguments not specified ([#​1172])
  • optionally specify where .parse() arguments "from", if not following node conventions ([#​512] [#​1172])
  • suggest help option along with unknown command error ([#​1179])
  • TypeScript definition for commands property of Command ([#​1184])
  • export program property ([#​1195])
  • createCommand factory method to simplify subclassing ([#​1191])
Fixed
Changed
  • Breaking .args contains command arguments with just recognised options removed ([#​1032] [#​1138])
  • Breaking display error if required argument for command is missing ([#​995] [#​1149])
  • tighten TypeScript definition of custom option processing function passed to .option() ([#​1119])
  • Breaking .allowUnknownOption() ([#​802] [#​1138])
    • unknown options included in arguments passed to command action handler
    • unknown options included in .args
  • only recognised option short flags and long flags are expanded (e.g. -ab or --foo=bar) ([#​1145])
  • Breaking .parseOptions() ([#​1138])
    • args in returned result renamed operands and does not include anything after first unknown option
    • unknown in returned result has arguments after first unknown option including operands, not just options and values
  • Breaking .on('command:*', callback) and other command events passed (changed) results from .parseOptions, i.e. operands and unknown ([#​1138])
  • refactor Option from prototype to class ([#​1133])
  • refactor Command from prototype to class ([#​1159])
  • changes to error handling ([#​1165])
    • throw for author error, not just display message
    • preflight for variadic error
    • add tips to missing subcommand executable
  • TypeScript fluent return types changed to be more subclass friendly, return this rather than Command ([#​1180])
  • .parseAsync returns Promise<this> to be consistent with .parse() ([#​1180])
  • update dependencies
Removed
  • removed EventEmitter from TypeScript definition for Command, eliminating implicit peer dependency on @types/node ([#​1146])
  • removed private function normalize (the functionality has been integrated into parseOptions) ([#​1145])
  • parseExpectedArgs is now private ([#​1149])
Migration Tips

If you use .on('command:*') or more complicated tests to detect an unrecognised subcommand, you may be able to delete the code and rely on the default behaviour.

If you use program.args or more complicated tests to detect a missing subcommand, you may be able to delete the code and rely on the default behaviour.

If you use .command('*') to add a default command, you may be be able to switch to isDefault:true with a named command.

If you want to continue combining short options with optional values as though they were boolean flags, set combineFlagAndOptionalValue(false) to expand -fb to -f -b rather than -f b.

v4.1.1

Compare Source

Fixed
  • TypeScript definition for .action() should include Promise for async ([#​1157])

v4.1.0

Compare Source

Added
  • two routines to change how option values are handled, and eliminate name clashes with command properties ([#​933] [#​1102])
    • see storeOptionsAsProperties and passCommandToAction in README
  • .parseAsync to use instead of .parse if supply async action handlers ([#​806] [#​1118])
Fixed
  • Remove trailing blanks from wrapped help text ([#​1096])
Changed
  • update dependencies
  • extend security coverage for Commander 2.x to 2020-02-03
  • improvements to README
  • improvements to TypeScript definition documentation
  • move old versions out of main CHANGELOG
  • removed explicit use of ts-node in tests

v4.0.1

Compare Source

Fixed
  • display help when requested, even if there are missing required options ([#​1091])

v4.0.0

Compare Source

Added
  • automatically wrap and indent help descriptions for options and commands ([#​1051])
  • .exitOverride() allows override of calls to process.exit for additional error handling and to keep program running ([#​1040])
  • support for declaring required options with .requiredOptions() ([#​1071])
  • GitHub Actions support ([#​1027])
  • translation links in README
Changed
  • dev: switch tests from Sinon+Should to Jest with major rewrite of tests ([#​1035])
  • call default subcommand even when there are unknown options ([#​1047])
  • Breaking Commander is only officially supported on Node 8 and above, and requires Node 6 ([#​1053])
Fixed
  • Breaking keep command object out of program.args when action handler called ([#​1048])
    • also, action handler now passed array of unknown arguments
  • complain about unknown options when program argument supplied and action handler ([#​1049])
    • this changes parameters to command:* event to include unknown arguments
  • removed deprecated customFds option from call to child_process.spawn ([#​1052])
  • rework TypeScript declarations to bring all types into imported namespace ([#​1081])
Migration Tips
Testing for no arguments

If you were previously using code like:

if (!program.args.length) ...

a partial replacement is:

if (program.rawArgs.length < 3) ...

v3.0.2

Compare Source

Fixed
  • Improve tracking of executable subcommands.
Changed
  • update development dependencies

v3.0.1

Compare Source

Added
Changed
  • consistently use const rather than var in README ([#​1026])
Fixed
  • help for sub commands with custom executableFile ([#​1018])

v3.0.0

Compare Source

  • Add option to specify executable file name ([#​999])
    • e.g. .command('clone', 'clone description', { executableFile: 'myClone' })
  • Change docs for .command to contrast action handler vs git-style executable. ([#​938] [#​990])
  • Breaking Change TypeScript to use overloaded function for .command. ([#​938] [#​990])
  • Change to use straight quotes around strings in error messages (like 'this' instead of `this') ([#​915])
  • Add TypeScript "reference types" for node ([#​974])
  • Add support for hyphen as an option argument in subcommands ([#​697])
  • Add support for a short option flag and its value to be concatenated for action handler subcommands ([#​599])
    • e.g. -p 80 can also be supplied as -p80
  • Add executable arguments to spawn in win32, for git-style executables ([#​611])
    • e.g. node --harmony myCommand.js clone
  • Add parent command as prefix of subcommand in help ([#​980])
  • Add optional custom description to .version ([#​963])
    • e.g. program.version('0.0.1', '-v, --vers', 'output the current version')
  • Add .helpOption(flags, description) routine to customise help flags and description ([#​963])
    • e.g. .helpOption('-e, --HELP', 'read more information')
  • Fix behavior of --no-* options ([#​795])
    • can now define both --foo and --no-foo
    • Breaking custom event listeners: --no-foo on cli now emits option:no-foo (previously option:foo)
    • Breaking default value: defining --no-foo after defining --foo leaves the default value unchanged (previously set it to false)
    • allow boolean default value, such as from environment ([#​987])
  • Increment inspector port for spawned subcommands ([#​991])
    • e.g. node --inspect myCommand.js clone
Migration Tips

The custom event for a negated option like --no-foo is option:no-foo (previously option:foo).

program
  .option('--no-foo')
  .on('option:no-foo', () => {
    console.log('removing foo');
  });

When using TypeScript, adding a command does not allow an explicit undefined for an unwanted executable description (e.g for a command with an action handler).

program
  .command('action1', undefined, { noHelp: true }) // No longer valid
  .command('action2', { noHelp: true }) // Correct

Configuration

📅 Schedule: Branch creation - At any time (no schedule defined), Automerge - At any time (no schedule defined).

🚦 Automerge: Disabled by config. Please merge this manually once you are satisfied.

♻ Rebasing: Whenever PR becomes conflicted, or you tick the rebase/retry checkbox.

🔕 Ignore: Close this PR and you won't be reminded about this update again.


  • [ ] If you want to rebase/retry this PR, check this box

This PR has been generated by Mend Renovate. View repository job log here.

Created at 2 weeks ago
renovate[bot] create branch renovate/commander-10.x
Created at 2 weeks ago

fix(deps): update dependency express to v4.18.2

fix(deps): update dependency sqlite3 to v5

Created at 2 weeks ago

fix(deps): update dependency express to v4.18.2

fix(deps): update dependency sequelize to v6

Created at 2 weeks ago

Fixes #277

Sequelize version was bumped along the way and now findByID is deprecated. The findByPk method works.

Merge pull request #387 from dtauer/patch-1

Fixes #277

fix(deps): update dependency express to v4.17.3 [security]

chore(deps): update dependency @types/lodash to v4.14.191

fix(deps): update dependency body-parser to v1.19.2

fix(deps): update dependency debug to v4.3.4

fix(deps): update dependency express-session to v1.17.3

fix(deps): update dependency body-parser to v1.20.1

fix(deps): update dependency express to v4.18.2

fix(deps): update dependency nodemon to v2

Created at 2 weeks ago

chore(deps): bump npm from 6.4.1 to 6.14.18

Bumps npm from 6.4.1 to 6.14.18.


updated-dependencies:

  • dependency-name: npm dependency-type: indirect ...

Signed-off-by: dependabot[bot] support@github.com

Created at 2 weeks ago

fix(deps): update dependency express to v4.18.2

fix(deps): update dependency bcrypt to v5 [security]

Created at 2 weeks ago

chore(deps): bump qs from 6.5.2 to 6.5.3

Bumps qs from 6.5.2 to 6.5.3.


updated-dependencies:

  • dependency-name: qs dependency-type: indirect ...

Signed-off-by: dependabot[bot] support@github.com

Created at 2 weeks ago

chore(deps-dev): bump semantic-release from 15.14.0 to 19.0.3

Bumps semantic-release from 15.14.0 to 19.0.3.


updated-dependencies:

  • dependency-name: semantic-release dependency-type: direct:development ...

Signed-off-by: dependabot[bot] support@github.com

Created at 2 weeks ago

chore(deps): bump ini from 1.3.4 to 1.3.8

Bumps ini from 1.3.4 to 1.3.8.

Signed-off-by: dependabot[bot] support@github.com

Created at 2 weeks ago

chore(deps): bump ejs from 2.7.4 to 3.1.7

Bumps ejs from 2.7.4 to 3.1.7.


updated-dependencies:

  • dependency-name: ejs dependency-type: direct:production ...

Signed-off-by: dependabot[bot] support@github.com

Created at 2 weeks ago

fix(deps): update dependency express to v4.18.2

chore(deps): update dependency semantic-release to v17 [security]

Created at 2 weeks ago

fix(deps): update dependency express to v4.18.2

chore(deps): bump npm from 6.4.1 to 6.14.18

Bumps npm from 6.4.1 to 6.14.18.


updated-dependencies:

  • dependency-name: npm dependency-type: indirect ...

Signed-off-by: dependabot[bot] support@github.com

Created at 2 weeks ago

fix(deps): update dependency express to v4.18.2

chore(deps): bump qs from 6.5.2 to 6.5.3

Bumps qs from 6.5.2 to 6.5.3.


updated-dependencies:

  • dependency-name: qs dependency-type: indirect ...

Signed-off-by: dependabot[bot] support@github.com

Created at 2 weeks ago

fix(deps): update dependency express to v4.18.2

chore(deps-dev): bump semantic-release from 15.14.0 to 19.0.3

Bumps semantic-release from 15.14.0 to 19.0.3.


updated-dependencies:

  • dependency-name: semantic-release dependency-type: direct:development ...

Signed-off-by: dependabot[bot] support@github.com

Created at 2 weeks ago

fix(deps): update dependency express to v4.18.2

chore(deps): bump ejs from 2.7.4 to 3.1.7

Bumps ejs from 2.7.4 to 3.1.7.


updated-dependencies:

  • dependency-name: ejs dependency-type: direct:production ...

Signed-off-by: dependabot[bot] support@github.com

Created at 2 weeks ago

fix(deps): update dependency express to v4.18.2

chore(deps): bump ini from 1.3.4 to 1.3.8

Bumps ini from 1.3.4 to 1.3.8.

Signed-off-by: dependabot[bot] support@github.com

Created at 2 weeks ago
renovate[bot] delete branch renovate/express-4.x
Created at 2 weeks ago

fix(deps): update dependency express to v4.18.2

Created at 2 weeks ago
fix(deps): update dependency express to v4.18.2

Mend Renovate

This PR contains the following updates:

| Package | Change | Age | Adoption | Passing | Confidence | |---|---|---|---|---|---| | express (source) | 4.17.3 -> 4.18.2 | age | adoption | passing | confidence |


Release Notes

v4.18.2

Compare Source

===================

  • Fix regression routing a large stack in a single route
  • deps: body-parser@1.20.1
    • deps: qs@6.11.0
    • perf: remove unnecessary object clone
  • deps: qs@6.11.0

v4.18.1

Compare Source

===================

  • Fix hanging on large stack of sync routes

v4.18.0

Compare Source

===================

  • Add "root" option to res.download
  • Allow options without filename in res.download
  • Deprecate string and non-integer arguments to res.status
  • Fix behavior of null/undefined as maxAge in res.cookie
  • Fix handling very large stacks of sync middleware
  • Ignore Object.prototype values in settings through app.set/app.get
  • Invoke default with same arguments as types in res.format
  • Support proper 205 responses using res.send
  • Use http-errors for res.format error
  • deps: body-parser@1.20.0
    • Fix error message for json parse whitespace in strict
    • Fix internal error when inflated body exceeds limit
    • Prevent loss of async hooks context
    • Prevent hanging when request already read
    • deps: depd@2.0.0
    • deps: http-errors@2.0.0
    • deps: on-finished@2.4.1
    • deps: qs@6.10.3
    • deps: raw-body@2.5.1
  • deps: cookie@0.5.0
    • Add priority option
    • Fix expires option to reject invalid dates
  • deps: depd@2.0.0
    • Replace internal eval usage with Function constructor
    • Use instance methods on process to check for listeners
  • deps: finalhandler@1.2.0
    • Remove set content headers that break response
    • deps: on-finished@2.4.1
    • deps: statuses@2.0.1
  • deps: on-finished@2.4.1
    • Prevent loss of async hooks context
  • deps: qs@6.10.3
  • deps: send@0.18.0
    • Fix emitted 416 error missing headers property
    • Limit the headers removed for 304 response
    • deps: depd@2.0.0
    • deps: destroy@1.2.0
    • deps: http-errors@2.0.0
    • deps: on-finished@2.4.1
    • deps: statuses@2.0.1
  • deps: serve-static@1.15.0
    • deps: send@0.18.0
  • deps: statuses@2.0.1
    • Remove code 306
    • Rename 425 Unordered Collection to standard 425 Too Early

Configuration

📅 Schedule: Branch creation - At any time (no schedule defined), Automerge - At any time (no schedule defined).

🚦 Automerge: Enabled.

♻ Rebasing: Whenever PR becomes conflicted, or you tick the rebase/retry checkbox.

🔕 Ignore: Close this PR and you won't be reminded about this update again.


  • [ ] If you want to rebase/retry this PR, check this box

This PR has been generated by Mend Renovate. View repository job log here.

Created at 2 weeks ago

fix(deps): update dependency express-session to v1.17.3

fix(deps): update dependency body-parser to v1.20.1

fix(deps): update dependency sqlite3 to v5

Created at 2 weeks ago

fix(deps): update dependency body-parser to v1.19.2

fix(deps): update dependency debug to v4.3.4

fix(deps): update dependency express-session to v1.17.3

fix(deps): update dependency body-parser to v1.20.1

fix(deps): update dependency sequelize to v6

Created at 2 weeks ago

fix(deps): update dependency body-parser to v1.20.1

fix(deps): update dependency chalk to v5

Created at 2 weeks ago