ivanistheone
Repos
122
Followers
171
Following
67

Events

%matplotlib inline no longer needed

Good catch.

One thing that is useful in modern notebooks is to issue the command:

%config InlineBackend.figure_format = 'retina'

which results in much higher resolution plots (beautiful).

Not sure if it's worth including/mentioning in the book, but would be nice to include in the provided notebooks.

Created at 1 day ago
Created at 1 day ago

Renamed xK02 --> ksample02 bcs seems nicer

Fix sec 1.3 nb issue

Created at 2 days ago
Created at 3 days ago

Update sec31 rvN->rvK, nsample20->xK02, nsample7->xK03; re-gen figs

Created at 4 days ago

Imported subsection and subsubsection headints into nbs

Created at 5 days ago

Restructured 31_estimators.ipynb to match new outline and .tex

Structured headings in 32_confidence_intervals.ipynb as per outline

Created at 1 week ago

Data generation scripts for doctors, tidy eprices, kombunchpop

Unorganized progress on Ch3 notebooks.

Adapted uses of eprices to new format

Created at 1 week ago
started
Created at 1 week ago
Created at 1 week ago

Data generation scripts for apples and kombucha

Created at 1 week ago
Created at 2 weeks ago
Created at 2 weeks ago
Created at 2 weeks ago
Created at 2 weeks ago
Created at 2 weeks ago
Created at 2 weeks ago

Cleanup landing page webcopy

Created at 2 weeks ago
Created at 3 weeks ago
issue comment
New sympy live doesn't work with safari browser

I opened this one https://github.com/jupyterlite/jupyterlite/issues/944 in the jupyterlite upstream repo so they are aware of it now.

We can still leave this issue open to keep track of it, and so we can coordinate testing once it's fixed.

Created at 3 weeks ago
issue comment
Update requirements.txt to match changes in jupyterlite/demo

Will this need to be done every time SymPy is updated, or was this just some bug that prevented it from being updated before?

When we run the command import sympy in during the initialization of the shell, we're getting whatever latest version is available in underlying pyodide.

Previously, the jupyterlite we were using was based on an older version of pyodide, which had sympy 1.10.1 in it, see https://pyodide.org/en/0.21.3/usage/packages-in-pyodide.html

And now, by switching to the latest jupyterlite, we're getting the latest pyodide too, which has 1.11.1

I think pyodide does some pre-processing complilation of sympy package in order to make it work in js-land; possibly because of mpmath. Otherwise pure-Python packages get pulled in directly from PyPI.

So to answer your question, there was no bug, but we're tied to the release cycle of pyodide and by jupyterlite.

Created at 3 weeks ago
Latest jupyterlite doesn't work under Safari in macOS

Description

When commands in https://jupyterlite.readthedocs.io/en/latest/_static/lab/index.html using Safari 16.1 (16614.2.9.1.13, 16614) on macOS 11.7.1 (20G918), I get the following error:

Note this was reported here: https://github.com/sympy/live/issues/16 when testing the sympy live shell

I just tested the pyodide console https://pyodide.org/en/stable/console.html and it seems to work fine in Safari, hence I believe it is a jupyterlite issue and opening here.

Reproduce

  1. Using Safari on a Mac
  2. Go to https://jupyterlite.readthedocs.io/en/latest/_static/lab/index.html
  3. Open a new pyodide notebook
  4. Try any command

Expected behavior

Run the command

Context

  • JupyterLite version: jupyterlite==0.1.0b17
Created at 3 weeks ago
closed issue
Update sympy version

Currently, the sympy version is locked to 1.10 in https://live.sympy.org/

import sympy
sympy.__version__
'1.10.1'

But the latest version is supposed to be 1.11 https://pyodide.org/en/stable/usage/packages-in-pyodide.html I'm not sure if this problem happens globally, but if is the case, we may need to find a fix of it

Created at 3 weeks ago
issue comment
Update sympy version

Fixed by updating to more recent versions of jupyterlab and jupyterlite in https://github.com/sympy/live/pull/15

Created at 3 weeks ago
push

Update requirements.txt to match version updates in jupyterlite/demo repo

Merge pull request #15 from sympy/update_jupyterlite

Update requirements.txt to match changes in jupyterlite/demo

Created at 3 weeks ago
pull request closed
Update requirements.txt to match changes in jupyterlite/demo

In issue https://github.com/sympy/live/issues/14 @sylee957 reports that the live shell is currently using an old version of sympy.

I tried triggering CI pipeline with this commit hoping this would include the latest version in the build, but that didn't do it (the sympy import is done at load time).

I'm therefore trying this new approach in this PR, which is to update the version of jupyterlite and jupyterlab we're using, to match what was done in the jupyterlite/demo/ commits:

  • https://github.com/jupyterlite/demo/pull/99/files#diff-28802fbf11c83a2eee09623fb192785e7ca92a3f40602a517c011b947a1822d3
  • https://github.com/jupyterlite/demo/pull/102/files
  • https://github.com/jupyterlite/demo/pull/103/files
Created at 3 weeks ago