freezy-sk
Repos
62
Followers
23
Following
45

:wrench: .files, including ~/.macos — sensible hacker defaults for macOS

0
0

Events

issue comment
Fix PHP 8.1 error

@bartoszkubicki no problem ;) and thank you for merge and release

Created at 1 week ago
freezy-sk delete branch fix-php-8.1
Created at 1 week ago
issue comment
Add to Packagist?

@mikeymike could you add it as a maintainer of other wearejh packagist packages?

Created at 1 week ago
issue comment
Fix PHP 8.1 error

@bartoszkubicki could you review it please?

Created at 1 week ago
Created at 1 week ago
Created at 2 weeks ago
Created at 3 weeks ago

fixed return types of get(), getRequired(), and getDataRequestPageSize()

Created at 1 month ago

call correctly typed methods of import config

Created at 1 month ago
pull request opened
Fix PHP 8.1 error

Magento running on PHP 8.1 raises fatal error:

During inheritance of Countable: Uncaught Exception: Deprecated Functionality: Return type of Jh\Import\Source\Db::count() should either be compatible with Countable::count(): int, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in /app/vendor/wearejh/m2-module-import/src/Source/Db.php on line 57 in /app/vendor/magento/framework/App/ErrorHandler.php:61

Also allowed monolog ^2.1 for development, which allows install on PHP 8.1 and added php-parallel-lint for fast syntax checking on PHP 7.4 and 8.1

Created at 1 month ago
freezy-sk create branch fix-php-8.1
Created at 1 month ago
Update phpstan/phpstan requirement from ~1.7.2 to ~1.8.2

@shochdoerfer this blocks all users of phpstan 1.7 from upgrading your extension to latest version. Is there some new required feature in 1.8? Changing ~1.7.2 to ^1.7.2 will allow 1.8 and still require 1.7.2 as minimum

Created at 1 month ago