felixsanz
Repos
14
Followers
11
Following
3

Events

closed issue
Don't work on sway?

Executing the command with wayvnc -L debug 0.0.0.0 5900 or even adding -s seat0 doesn't seem to work fine.

No error is printed and port seems to be used:

tcp        0      0 0.0.0.0:5900            0.0.0.0:*               LISTEN      243267/wayvnc        off (0.00/0/0)

But when I connect, all the applications I tried just say "unable to connect", and wayvnc prints:

Info: New client connection: 0x5563b8488bd0 (ref 1)
Info: Closing client connection 0x5563b8488bd0: ref 0

For every new try, that happens over and over again. What is the error then?

Created at 1 week ago
issue comment
Don't work on sway?

Sorry but I don't have currently time to backtrace segmentation faults. I'll reopen the issue when I find spare time.

If my message was not understood, I said "wayland is hell atm", not wayvnc. Of course I can help debug/fix wayvnc, but guess what? This probably has nothing to do with wayvnc. Nvidia broke their EGL rendering in the latest drivers update, I'm having a ton of flickering, etc. Wayland is the problem here, so I just said that i'll wait a bit more for it to mature, and then I'll re-take a look at wayvnc and why it don't works.

I'm having a lot of issues, like vscode scrolling jumping around, etc. I just can't spend days fixing every app because wayland is still very alpha. Hope you can understand why I don't want to continue backtracing just yet.

Created at 1 week ago
issue comment
Inside Selects, font color is the same as background

It was an issue on my firefox / userChrome.css ! Sorry!

Created at 1 week ago
closed issue
Inside Selects, font color is the same as background

An image that worth 1000 words:

1673286509

Created at 1 week ago
issue comment
Don't work on sway?

And we could probably look at the errors, if you'd like to post some?

it's just a segmentation fault, there is no error output :/ Anyway i don't think this is going to work. Even when it do... everything is blue and corrupted/weird. I'll wait a bit more, wayland is hell atm

Created at 1 week ago
issue comment
Inside Selects, font color is the same as background

no, i'm using https://github.com/catppuccin/firefox. maybe that's the issue? edit: naah, disabled it, still happening! edit2: btw if I change to adwaita... it works fine. so it's this gtk theme indeed?

Do you have some other place where I can contact? Like joining catppuccin discord/telegram username and such? I cannot reproduce it on my end and talking it in GitHub comments is kind of inconvenient when I would have to ask you to test a few changes

I'm on catppuccin discord, you can find me with the same name

Created at 1 week ago
issue comment
Inside Selects, font color is the same as background

no, i'm using https://github.com/catppuccin/firefox. maybe that's the issue?

Created at 1 week ago
issue comment
Inside Selects, font color is the same as background

still happening :/

Created at 1 week ago
issue comment
Inside Selects, font color is the same as background

I'm using sway/wayland

Were you using latte version of the theme?

mocha, the darkest one

Created at 1 week ago
issue comment
Inside Selects, font color is the same as background

I'm using sway/wayland

Created at 1 week ago
issue comment
Don't work on sway?

This has been fixed when using the latest git version, but there is a lot of errors, seg faults, weird colors when you are lucky to connect... :/

Created at 1 week ago
issue comment
Can't build git version on arch

The problem is aml provides "libaml.so" and aml-git provides "aml".

Both neatvnc-git and wayvnc-git needs libaml.so, so only aml can satisfy. Modiying both PKGBUILD to depend on aml instead of libaml.so fixes it.

Created at 1 week ago
issue comment
Can't build git version on arch

I think the problem is aml-git not having provides=(libaml.so)

Created at 1 week ago
opened issue
Can't build git version on arch

Basically wayvnc-git needs aml-git, but you can't install it because wayvnc-git also needs neatvnc-git.

And neatvnc-git needs aml, not aml-git

Created at 1 week ago
opened issue
Don't work on sway?

Executing the command with wayvnc -L debug 0.0.0.0 5900 or even adding -s seat0 doesn't seem to work fine.

No error is printed and port seems to be used:

tcp        0      0 0.0.0.0:5900            0.0.0.0:*               LISTEN      243267/wayvnc        off (0.00/0/0)

But when I connect, all the applications I tried just say "unable to connect", and wayvnc prints:

Info: New client connection: 0x5563b8488bd0 (ref 1)
Info: Closing client connection 0x5563b8488bd0: ref 0

For every new try, that happens over and over again. What is the error then?

Created at 1 week ago
Publish extension to codium marketplace (open VSX)

Please! Can't live without this extension xD Can you publish it to the codium marketplace?

https://open-vsx.org/ https://github.com/eclipse/openvsx/wiki/Publishing-Extensions

Created at 1 week ago
Publish extension to codium marketplace (open VSX)

Hi :)

So I've done .. something. I'm waiting on Eclipse to verify my namespace or something?

https://open-vsx.org/extension/baobaozi/sort-selection-concentrically

I'm not entirely sure if it's available to use or it needs to wait for the verification. But let me know if you are able to install it already.

HTH!

it works! I'm able to install it and works fine. Thanks so much!

Created at 1 week ago
Publish extension to codium marketplace (open VSX)

Please can you publish it to the codium marketplace too?

https://open-vsx.org/ https://github.com/eclipse/openvsx/wiki/Publishing-Extensions

Created at 1 week ago
issue comment
Bug: OCI runtime exec failed: exec failed: container_linux.go:367: starting container process caused: exec: "sh": executable file not found in $PATH: unknown

@chenilim i'm having it. it's indeed related to running this with user nobody

Created at 1 week ago
Created at 1 week ago
issue comment
Inside Selects, font color is the same as background

Firefox, but any select will do.

1673788040

Created at 1 week ago
Publish extension to codium marketplace (open VSX)

Please! Can't live without this extension xD Can you publish it to the codium marketplace?

https://open-vsx.org/ https://github.com/eclipse/openvsx/wiki/Publishing-Extensions

Created at 2 weeks ago
What's the point of this self-hosted project?

@felixsanz The web-app and sync server are separate projects - https://github.com/standardnotes/app is the web app, and includes some docker instructions and a sample .env file. Agreed that documentation could be better, but at least the information needed to get something live is there. Here's how I have set up the web-app with docker-compose in case it's helpful: https://github.com/eric-pierce/Personal-Cloud/blob/main/docker-compose.yml#L834

Thanks for your personal docker-compose.yml, that's helpful! But that also proves that official docs are (hard? inexistent?).

So to able to run standard notes completely self-hosted I do need the web app, the sync server, the many workers stuff, the auth stuff, etc etc, right? Or it's only the web app and i'm doing it wrong?

Created at 2 weeks ago
issue comment
User unable to login via SSO after modifying profile details

Just was about to report this xD it's happening to me too :(

Created at 2 weeks ago
What's the point of this self-hosted project?

Documentation is found on the standardnotes site: https://docs.standardnotes.com/self-hosting/getting-started/

Yes, and you scroll down to the Web application and the only link redirects you to https://github.com/standardnotes/app/tree/main/packages/web

which is just a repo with a bunch of files, no readme and no instructions

Created at 2 weeks ago
issue comment
Cannot ping network alias of container where multiple networks exist

@baude it isn't. #14262 and #14345

Created at 2 weeks ago
issue comment
/etc/resolv.conf nameserver order varies when starting a container with multiple networks.

aren't this and #14345 the same bug?

Created at 2 weeks ago
issue comment
netavark dns resolves container fqdn on only one network when multiple networks connected

Bump. Happening to me and it's very annoying! @flouthoc I can confirm this works as expected in docker, been using this networking stuff for years

Created at 2 weeks ago
issue comment
Doesn't run on Arch

If it just hangs it might be something else. Is there any CPU usage or something similar?

I deleted the package already so reinstalled it again and now I can see an error:

❯ sunflower     
Traceback (most recent call last):
  File "/usr/lib/python3.10/site-packages/sunflower/__main__.py", line 165, in do_activate
    self.window = MainWindow(
  File "/usr/lib/python3.10/site-packages/sunflower/gui/main_window.py", line 87, in __init__
    self._load_styles()
  File "/usr/lib/python3.10/site-packages/sunflower/gui/main_window.py", line 931, in _load_styles
    provider.load_from_file(Gio.File.new_for_path(file_name))
gi.repository.GLib.GError: gtk-css-provider-error-quark: <broken file>:1:0Failed to import: Error opening file /usr/lib/python3.10/site-packages/styles/main.css: No such file or directory (2)
Created at 2 weeks ago
What's the point of this self-hosted project?

First of all thanks for releasing it open source, but what's the point in doing it this way? The repos don't even have a README.

Example: https://hub.docker.com/r/standardnotes/web

There is no documentation and everything seems just so complicated so that people give up and pay the official version.

Created at 2 weeks ago