don-wang
Repos
26
Followers
4
Following
1

Events

issue comment
svelte version dependency in 0.7.3

@BeeMargarida

Thank you for your work. Unfortunately, it seems the '>=' is still being stripped as Brisklemonade metioned

I got this error when run npm install

npm ERR! Could not resolve dependency:
npm ERR! peer svelte@"3.47.0" from @svelteuidev/core@0.7.6
npm ERR! node_modules/@svelteuidev/core
npm ERR!   @svelteuidev/core@"^0.7.6" from the root project
npm ERR! 
npm ERR! Conflicting peer dependency: svelte@3.47.0
npm ERR! node_modules/svelte
npm ERR!   peer svelte@"3.47.0" from @svelteuidev/core@0.7.6
npm ERR!   node_modules/@svelteuidev/core
npm ERR!     @svelteuidev/core@"^0.7.6" from the root project
npm ERR! 

It works with npm install --legacy-peer-deps, then in the node_modules/@svelteuidev/core/package.json, it shows

  "peerDependencies": {
    "@svelteuidev/composables": "0.7.6",
    "svelte": "3.47.0"
  },

Same as in node_modules/@svelteuidev/preprocessors/package.json

Created at 1 hour ago
Created at 3 weeks ago
issue comment
svelte version dependency in 0.7.3

@BeeMargarida Sorry, I got the same error in 0.7.5

npm ERR! peer svelte@"3.47.0" from @svelteuidev/core@0.7.5
Created at 1 month ago
issue comment
svelte version dependency in 0.7.3

@luisjakon I used npm install --legacy-peer-deps as temporary solution

Created at 1 month ago
opened issue
svelte version dependency in 0.7.3

What package has an issue

@svelteuidev/core

A clear and concise description of what the bug is

the latest dev release seems to explicitly state svelte 3.47.0 as the peer dependency.

svelte version dependency #186 The same issue had been fixed and closed, but I got the same error in the latest 0.7.3 ver.

In which browser(s) did the problem occur?

No response

Steps To Reproduce

In package.json, using "svelte": "3.49.0" as devDependencies, "@svelteuidev/core": "^0.7.3", as dependencies

by run npm install

got error:

npm ERR! Could not resolve dependency:
npm ERR! peer svelte@"3.47.0" from @svelteuidev/core@0.7.3
npm ERR! node_modules/@svelteuidev/core
npm ERR!   @svelteuidev/core@"^0.7.3" from the root project
npm ERR! 
npm ERR! Conflicting peer dependency: svelte@3.47.0
npm ERR! node_modules/svelte
npm ERR!   peer svelte@"3.47.0" from @svelteuidev/core@0.7.3
npm ERR!   node_modules/@svelteuidev/core
npm ERR!     @svelteuidev/core@"^0.7.3" from the root project

Do you know how to fix the issue

No

Are you willing to participate in fixing this issue and create a pull request with the fix

Yes

Relevant Assets

No response

Created at 2 months ago
issue comment
Build error on TypeScript enabled project

@Brisklemonade May I ask when next patch will be released?

Created at 2 months ago

add referral code pattern

Created at 2 months ago

close liff after sent msg

Created at 2 months ago

update fallback

Created at 2 months ago

update qr url 3

update qr url 4

Created at 2 months ago

update qr url

Created at 2 months ago

update qr url

Created at 2 months ago

update redirect

Created at 2 months ago

update share func

Created at 2 months ago

update share func

Created at 2 months ago

update liff fun

Created at 2 months ago
create branch
don-wang create branch develop
Created at 2 months ago
create branch
don-wang create branch main
Created at 2 months ago
create repository
don-wang create repository
Created at 2 months ago
issue comment
[BUG] Cannot set properties of undefined

I got the same error. Looking forward to solutions

Created at 2 months ago
Created at 2 months ago
Created at 2 months ago
issue comment
[svelte-kit] Cannot Load ES module from agnostic-helpers

May I ask when will this fix be updated to NPM package?

Created at 2 months ago