dbarzin
Repos
13
Followers
16
Following
9

Cartographie du système d'information / Mapping the information system

72
16

Outil de gestion du système de management de la sécurité de l'information

4
0

USB Scanning device

10
0

Events

missing label

fix label

update label

update labels

Merge pull request #224 from dbarzin/dev

Update some labels

Created at 18 hours ago
pull request closed
Update some labels
Created at 18 hours ago
pull request opened
Update some labels
Created at 18 hours ago

update label

update labels

Created at 18 hours ago
Created at 3 days ago

fix label

Created at 6 days ago

missing label

Created at 6 days ago

fix links in report page

Merge pull request #221 from dbarzin/dev

fix links in report page

Created at 6 days ago
pull request closed
fix links in report page

Fixed at Brucon 2022 !

Created at 6 days ago
pull request opened
fix links in report page

Fixed at Brucon 2022 !

Created at 6 days ago

fix links in report page

Created at 6 days ago

fix invalid table

Merge pull request #220 from dbarzin/dev

fix invalid table

Created at 1 week ago
pull request closed
fix invalid table
Created at 1 week ago
pull request opened
fix invalid table
Created at 1 week ago
issue comment
Use of deleted table in logical report view

Corrigé.

Created at 1 week ago

fix invalid table

Created at 1 week ago
issue comment
Poetry install command has changed

Thanks for the hint !

Created at 1 week ago
issue comment
Pandora service not starting on boot

Thank you, I will fix that and create a GitHub Action to test the installation and ensure non regressions.

Created at 1 week ago
Created at 1 week ago

new tests

add error image

Created at 1 week ago
issue comment
Procédure d'installation non concluante

Il faut composer2 et PHP 8. Pour composer : https://getcomposer.org/download/ Pour PHP 8 : https://linuxhint.com/install-php-8-on-linux-mint-20/

Created at 1 week ago
closed issue
Installation erreur PHP

Bonjour,

Je rencontre un problème lors de l'initialisation de la base de données MySQL. Lorsque je lance la commande php artisan migrate --seed, une erreur (ci-dessous) apparait au moment de traiter le fichier Role.php

image

Malgré cela, je continue l'install jusqu'au bout, j'arrive à accéder à l'interface de connexion mais les identifiants par défaut (admin@admin.com / password) ne fonctionnent pas. Je pense que le script PHP n'a pas fait le boulot jusqu'au bout à cause de l'erreur sur le Role.php.

Quand pourraisè-e débuguer ce problème et réussir à me connecter à l'application ?

Merci par avance pour votre aide.

Created at 2 weeks ago
issue comment
Installation erreur PHP

Peux-tu essayer de réinstaller la DB

php artisan migrate:fresh --seed


                            
Created at 2 weeks ago
issue comment
Installation erreur PHP

J'ai la même erreur mais cela n'a pas d'impact. Les crédentials par défaut sont : admin@admin.com / password

Created at 2 weeks ago
issue comment
Installation erreur PHP

Pour le message d'erreur, cela ne doit pas poser de problème. Tu essayes bien d'ouvrir l'URL http://127.0.0.1:8000 ?

Le mar. 20 sept. 2022 à 21:39, GoodFeel91 @.***> a écrit :

Idem, impossible de me connecter à l'appli, avec la même erreur LDAP. J'ai vérifié le fichier .env, la partie LDAP est bien commentée.

— Reply to this email directly, view it on GitHub https://github.com/dbarzin/mercator/issues/215#issuecomment-1252821394, or unsubscribe https://github.com/notifications/unsubscribe-auth/AKJU4KFXAK2IJUBUUH627GDV7IHGZANCNFSM6AAAAAAQQ7RFWA . You are receiving this because you were assigned.Message ID: @.***>

Created at 2 weeks ago
issue comment
Installation erreur PHP

essaye

php artisan serve --host 0.0.0.0 --port 8000

Le mar. 20 sept. 2022 à 21:16, GoodFeel91 @.***> a écrit :

Effectivement, j'ai passé la version de PHP en 8.x et fait un git pull et la commande php artisan migrate passe bien sans erreur.

Par contre, toujours impossible de me connecter à l'interface avec les identifiants par défaut.

Je lance la commande

php artisan serve --host 192.168.1.178 --port 8000

correspondant à mon serveur.

J'ai trouvé trace d'une log dans storage/logs/laravel.log

[2022-09-20 19:14:07] local.INFO: LDAP (ldap://127.0.0.1:389) - Operation: Binding - Username: cn=user,dc=local,dc=com

[2022-09-20 19:14:07] local.ERROR: Can't contact LDAP server {"code":null}

Il semble tenter une connexion LDAP alors que je n'ai pas configuré cette partie.

— Reply to this email directly, view it on GitHub https://github.com/dbarzin/mercator/issues/215#issuecomment-1252799575, or unsubscribe https://github.com/notifications/unsubscribe-auth/AKJU4KBSPCF3GIQZIVKT4C3V7IEQJANCNFSM6AAAAAAQQ7RFWA . You are receiving this because you were assigned.Message ID: @.***>

Created at 2 weeks ago
issue comment
Installation erreur PHP

Il faut utiliser PHP version >= 8.0. Composer a du l'installer mais elle n'est pas dans ton PATH.

Puis, il faut mettre à jour le projet avant

git pull

en ensuite :

php artisan migrate


                            
Created at 2 weeks ago
issue comment
Installation erreur PHP

Bonjour,

Le problème est probablement corrigé mais cela ne se produit pas lors des tests d'intégration ni dans mon environnement de développement.

Il faut reprendre l'installation à

php artisan migrate --seed

Quelle version de PHP utilises-tu ? Quel OS ?

Created at 2 weeks ago
pull request closed
Dev

Fix typo

Created at 2 weeks ago

Merge pull request #212 from dbarzin/master

Rebase

fix typo

Merge branch 'dev' of github.com:dbarzin/mercator into dev

Merge pull request #216 from dbarzin/dev

Dev

Created at 2 weeks ago